Bankserv experiencing downtime
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted May 17, 2024 - 14:21 SAST
Investigating
Please note that there is currently downtime on bankserv affecting 3DSecure transactions.

The Bankserv team is currently investigating and we will provide updates as they become available.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted May 17, 2024 - 13:07 SAST