ABSA planned maintenance - CHG0765944

Scheduled for Jun 21, 22:00 SAST  -  Jun 22, 22:00 SAST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 02, 2026 - 12:09 SAST

Scheduled

ABSA will be performing Arista network switch EOS upgrade - 270RR Trusted Network switches from Sunday 21 June 2026 at 22:00pm to Monday 22 June 2026 at 22:00pm.

During the maintenance window, ABSA do not expect any service impact. However, intermittent connectivity may be experienced.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jun 02, 2026 - 12:02 SAST
This scheduled maintenance affects: Third-party Platforms (Absa card acquiring).