Nedbank planned maintenance, CHG0141642

Scheduled for Feb 21, 00:00 - 06:00 SAST

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 16, 2026 - 14:56 SAST

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 16, 2026 - 13:12 SAST

Scheduled

Nedbank will be performing a scheduled maintenance on their platform.

Date: Saturday, 21 February 2026
Time: 00:00 AM – 06:00 AM SAST

During the maintenance window services may be intermittently affected.

If you have any questions or concerns, please contact support@peachpayments.com
or reach out to your Account Manager.
Posted Feb 16, 2026 - 13:10 SAST
This scheduled maintenance affects: Third-party Platforms (Nedbank card acquiring).