Standard Bank - intermittent performance

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Oct 16, 2022 - 19:44 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2022 - 12:36 SAST

Investigating

Standard Bank users are experiencing intermittent performance to complete payments.
Posted Oct 16, 2022 - 10:40 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).