EFTSecure - intermittent downtime
Incident Report for Peach Payments
Resolved
EFTSecure intermittent performance: duration:
The incident started at 2023-03-15 09:30:30
Resolved at 2023-03-15 09:35:29
During this time it was observed intermittent performance of EFTSecure and potentially affected a limited number of transactions.
Our engineers have resolved at 2023-03-15 09:35:29
Posted Mar 15, 2023 - 12:28 SAST
This incident affected: Third-party Platforms (EFT Secure).