The issue has been resolved and all transactions are now being processed successfully on Peach Devices.
We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jan 26, 2025 - 14:43 SAST
Identified
The issue has been identified and a temporary fix has been deployed. Transactions are processing successfully but however, there will be intermittent failures until the permanent fix is deployed.
Our engineers are working on it and we will continue to update this status page as we make progress.
Posted Jan 26, 2025 - 14:19 SAST
Investigating
We are currently experiencing an issue where transactions are not going through on our in-store devices only. Online transactions are not impacted. Our team is investigating the issue and working to resolve it as soon as possible.
We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.