Dashboard Issue - Peach Payments

Incident Report for Peach Payments

Resolved

This incident has been resolved. We are still seeing ongoing recovery while previous transactions are bing updated, however all new transactions are reflecting as expected.
Posted Jul 29, 2024 - 20:19 SAST

Update

Please ignore the previous update as it was erroneously sent - There is no transactional impact.

Our engineers are continuing to work on the fix and we shall provide updates once the issue is resolved. Thank you.
Posted Jul 29, 2024 - 18:03 SAST

Update

The work for the fix is in progress and we have additionally identified the below issues:
- Payment Links unavailable via API for merchants
- Partner API authentication unavailable

Therefore, it might be causing intermittent transaction declines. Thank you.
Posted Jul 29, 2024 - 17:10 SAST

Identified

The issue has been identified as an AWS service failure. Our engineers are working closely with the AWS provider to resolve the issue.

Important note: Transactions are processing correctly - You might only encounter delay for the transactions to appear on the dashboard.

We will keep you posted for any future updates. Thank you.
Posted Jul 29, 2024 - 16:53 SAST

Investigating

Hi,

Peach Payments has been alerted of one of its services not functioning - Our engineers are currently investigating and will ensure that the service is up and running.

As at now, you might experience delay for your recent transactions to display on the Peach Dashboard. We will keep you posted on the events.

For any further queries or clarification, please reach out to support@peachpayments.com.
Posted Jul 29, 2024 - 16:24 SAST
This incident affected: Support (Dashboard - Peach Payments) and Plugins and Platforms (Payment Links).