Apple Pay – Degraded Performance on Checkout Integrations

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted May 18, 2026 - 18:48 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 18, 2026 - 13:26 SAST

Investigating

Apple Pay is currently experiencing degraded performance on Checkout integration, which may prevent some customers from successfully completing payments.

Our team is actively investigating the issue and working to restore normal service as quickly as possible.

We apologise for the inconvenience and will continue to provide updates on this status page as progress is made.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted May 18, 2026 - 12:24 SAST
This incident affected: Checkout.