Intermittent Transaction Failures - BANKSERV
Incident Report for Peach Payments
Resolved
This incident has been resolved. Thank you.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 26, 2024 - 07:16 SAST
Investigating
Peach Payments Team has been informed by Acquirers that there are intermittent transaction failures due to an issue on Bankserv side. The acquirers are working closing with Bankserv engineers to resolve the issue.

Regular updates will be posted on the incident.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 19, 2024 - 10:56 SAST
This incident affected: Plugins and Platforms (Magento, WooCommerce, Shopify, Payment API, Wix, Payment Links), Peach card processing platform, Checkout, and Third-party Platforms (Absa card acquiring, FNB card acquiring, Nedbank card acquiring, Peach card acquiring).