VOIP Telephone system is unavailable

Incident Report for Peach Payments

Resolved

Our provider has informed that the issue has been resolved.

We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Mar 20, 2025 - 12:22 SAST

Investigating

VOIP Telephone system is currently unavailable. Kindly reach out to Peach support using support@peachpayments.com and our agents will assist further.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Mar 20, 2025 - 10:51 SAST
This incident affected: Support (Phone Support).