Intermittent FNB Cards Failures
Incident Report for Peach Payments
Resolved
FNB has informed that the issue is resolved on their side - We are monitoring on our side and will escalate to FNB for any further degraded performance.

Thank you
Posted Jun 29, 2024 - 14:18 SAST
Investigating
We have been alerted by Bankserv that First National Bank Cards are being declined intermittently on all acquirers. Upon reaching out to FNB, they confirmed that there is an ongoing issue on their side. Their team is working to resolve it.

More information will be provided on our next follow up with the Bank. Please reach out to support@peachpayments.com with any questions or concerns.
Posted Jun 29, 2024 - 13:33 SAST
This incident affected: Peach card processing platform and Third-party Platforms (FNB card acquiring, Issuing systems for Card processing).