Peach Card Present and Card not Present some Aggregated merchants

Incident Report for Peach Payments

Resolved

The issue has been resolved.

We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Aug 04, 2025 - 05:27 SAST

Monitoring

The issue has been identified and our engineer has restored the Instore services. Our team is currently monitoring and will continue to update this status page as we make progress.
Posted Aug 03, 2025 - 18:03 SAST

Update

In-store services are currently down. Our team is investigating the issue and working to resolve it as soon as possible.
Posted Aug 03, 2025 - 17:12 SAST

Update

Peach Aggregations and Shopify and Wix merchant services have been restores.

Peach In-store POS is degraded.
Posted Aug 03, 2025 - 16:49 SAST

Update

Some card present POS merchant may be impacted until the incident is resolved.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Aug 03, 2025 - 16:08 SAST

Update

Some card present POS merchant may be impacted until the incident is resolved.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Aug 03, 2025 - 16:06 SAST

Investigating

Peach Card Present POS
Card present transactions are down, and there's also a small impact on card-not-present transactions for some Aggregated merchants.
ISO - (Independent Sales Organisations) merchants are not impacted
Impacted platforms
Wix Shopify
Posted Aug 03, 2025 - 15:46 SAST
This incident affected: Peach card processing platform, In-store card processing (In-store card processing - Absa Card Present, In-store card processing - Nedbank Card Present), Plugins and Platforms (Shopify, Wix), and Third-party Platforms (Peach card acquiring).