Capitec Pay downtime
Incident Report for Peach Payments
Resolved
Capitec Pay has been restored. The Capitec team are still further investigating what the issue was and how to prevent it going forward.

Please reach out to support@peachpayments.com with any questions or concerns
Posted Mar 22, 2024 - 19:55 SAST
Update
We are continuing to investigate this issue.
Posted Mar 22, 2024 - 18:31 SAST
Investigating
Please note that all Capitec Pay transactions are failing at the moment. They are failing with 900.100.100 (unexpected communication error with connector/acquirer).

The Capitec team are investigating and we will provide any updates from them as soon as received.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Mar 22, 2024 - 18:30 SAST
This incident affected: Third-party Platforms (Capitec Pay).