3D Secure Issue

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 19:16 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2025 - 19:06 SAST

Investigating

ABSA is experiencing an issue with 3ds leg of the transaction affecting Card transaction completion. The team is investigating, and we will keep you updated as they progress.

We apologise for any inconvenience caused and will continue to update this status page as they make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 11, 2025 - 18:28 SAST
This incident affected: Third-party Platforms (Absa card acquiring).