Aplus store cards
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Oct 01, 2023 - 22:47 SAST
Update
We are continuing to work on a fix for this issue.
Posted Oct 01, 2023 - 22:47 SAST
Update
We are continuing to work on a fix for this issue.
Posted Oct 01, 2023 - 21:44 SAST
Update
We are continuing to work on a fix for this issue.
Posted Oct 01, 2023 - 21:43 SAST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 01, 2023 - 21:43 SAST
Investigating
We are currently experiencing issues with processing A+ Card transactions. We are currently working with the A+ Team to resolve the issue.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Oct 01, 2023 - 17:49 SAST
This incident affected: Third-party Platforms (A+).