Issue with Peach In-store and card processing platform

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 22:02 SAST

Investigating

Our team is investigating an issue affecting Peach In-store card processing and refund via Peach card processing platform and is working to resolve it as soon as possible. This will affect merchants processing transactions to Nedbank and cause degraded service/all transactions to fail.

We apologise for any loss of service and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Mar 04, 2026 - 20:44 SAST
This incident affected: Peach card processing platform and In-store card processing (In-store card processing - Nedbank Card Present).