Platforms/Services downtime - Cloudflare network issue

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 07:17 SAST

Monitoring

Monitoring - Cloudflare has implemented a fix.

We are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 16:56 SAST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 15:43 SAST

Identified

Our platforms and services are experiencing intermittent downtime as a result of a widespread Cloudflare connectivity issue.
Among the affected Services/Platforms:

Dashboard
Freshdesk
Payout Services
Payment processing
Reconciliation services

Please note that we are available on our support line, as we wait for the fix on cloudflare side.
Posted Nov 18, 2025 - 14:14 SAST
This incident affected: Support (Freshdesk Peach Payments Support email).