Tyme Bin, banks are experiencing intermittent timeouts from Tyme
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Dec 31, 2021 - 19:37 SAST
Investigating
Tyme Bin, banks are experiencing intermittent timeouts from Tyme
Posted Dec 31, 2021 - 16:27 SAST
This incident affected: Third-party Platforms (Tyme bank card acquiring).