Capitec and Standard bank cards seeing higher than usual rejections
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jan 12, 2022 - 19:27 SAST
Investigating
We have escalated this issue and and investigation is underway with Bankserv to identify why Standard Bank and Capitec cards are rejecting for ecommerce transactions
Posted Jan 12, 2022 - 17:39 SAST
This incident affected: Third-party Platforms (Nedbank card acquiring).