In-Store Services Unavailable

Incident Report for Peach Payments

Resolved

This incident has been resolved. All transactions are now being processed successfully on Peach Devices.
Posted Jan 30, 2025 - 13:59 SAST

Monitoring

We confirm that the In Store services are now available. A fix has been implemented and our team is monitoring the results.
Posted Jan 27, 2025 - 09:37 SAST

Update

We are continuing to investigate this issue.
Posted Jan 27, 2025 - 09:12 SAST

Investigating

We are currently experiencing an issue where In-Store transactions are failing. Online transactions are not impacted. Our team is investigating the issue and working to resolve it as soon as possible.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jan 27, 2025 - 09:10 SAST
This incident affected: In-store card processing (In-store card processing - Absa Card Present).