Capitec - intermittent performance - Failures at 3D secure
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Sep 27, 2023 - 22:55 SAST
Investigating
A problem with Capitec has been identified. We have notified Capitec.
This is happening during the authentication within the Capitec App.

Thank you for your continued support.
If you have any questions, please reach out to our support team to assist - support@peachpayments.com or reach out to your Peach Payments account manager.
Posted Sep 27, 2023 - 21:08 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).