Payment Links Bulk Uploads not working
Incident Report for Peach Payments
Resolved
Please note the issue has been identified and a fix has been implemented.

This functionality is now restored.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Apr 18, 2024 - 10:23 SAST
Investigating
Please note, that there is currently an issue where Bulk Uploads for Payment Links are not working.

Our team are investigating and we will provide updates as they become available.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Apr 18, 2024 - 09:20 SAST
This incident affected: Plugins and Platforms (Payment Links).