Checkout - investigating incident

Incident Report for Peach Payments

Resolved

This incident has been resolved - an RCA will be shared by Monday 31 August 2026
Posted Aug 30, 2026 - 07:26 SAST

Investigating

We are currently experience downtime on our Peach Payments checkout, whereby cardholders are unable to checkout.
Posted Aug 30, 2026 - 07:03 SAST
This incident affected: Checkout.