High rate of declines for M-PESA transactions

Incident Report for Peach Payments

Update

We are still seeing rejections and M-Pesa have identified and implementing a fix, no ETA as yet
Posted Dec 12, 2025 - 11:03 SAST

Monitoring

we are currently monitoring as the event has cleared
Posted Dec 12, 2025 - 10:50 SAST

Investigating

We are currently reaching out to our downstream partner to determine the high rate of rejections, we will update as we are able to determine the cause
Posted Dec 12, 2025 - 10:42 SAST
This incident affects: Third-party Platforms (MPESA).