Sandbox Checkout – Card Payments Issue

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 18:37 SAST

Investigating

We are currently investigating an issue where card transactions on Checkout in Sandbox are failing. Our team is actively looking into this and we will provide updates as soon as we have more information.

Please reach out to support@peachpayments.com or your Account Manager with any questions or concerns.
Posted Aug 19, 2025 - 15:31 SAST
This incident affected: Checkout.