Intermittent downtime - Checkout, Payment Links and Dashboard
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 08:27 SAST
Monitoring
On 23 April 2024, a deployment issue resulted in downtime for certain products and components between 15:58 and 16:00 SAST:

- Checkout: A small number of customers were unable to pay via Checkout but could retry after two minutes. Transactions that were already in progress were unaffected.
- Payment Links: Merchants were unable to create payment links.
- Dashboard was unavailable.

We sincerely apologise for any inconvenience caused.

Please contact support@peachpayments.com or your account manager if you have any questions.
Posted Apr 24, 2024 - 08:26 SAST
This incident affected: Checkout, Support (Dashboard - Peach Payments), and Plugins and Platforms (Payment Links).