Payflex currently unavailable

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 13:36 SAST

Investigating

Payflex have advised that they are investigating downtime on their end, we will continue to update as we are made aware of any changes.
Posted Nov 28, 2025 - 12:43 SAST
This incident affected: Third-party Platforms (Payflex).