Mpesa downtime

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 17:41 SAST

Monitoring

We are noticing recovery of Mpesa transactions. We will keep monitoring the results.
Posted Apr 04, 2025 - 17:11 SAST

Investigating

Please note we are currently seeing intermittent downtime with Mpesa transactions. The team is investigating, and we will keep you updated as they progress.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 04, 2025 - 14:04 SAST
This incident affected: Third-party Platforms (MPESA).