Call Centre Service Disruption

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted May 20, 2026 - 15:47 SAST

Investigating

We are currently experiencing issues with our call centre lines, which may prevent callers from reaching our support team via phone.

Please note that this issue only affects inbound and outbound calls. Our support email channel remains fully operational, and merchants can continue to reach us at support@peachpayments.com.

Our team is actively investigating the issue and working to restore full call functionality as soon as possible.

We apologise for the inconvenience and appreciate your patience.
Posted May 20, 2026 - 14:46 SAST
This incident affected: Support (Phone Support).