Nedbank acquiring - intermitted downtime
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 19:16 SAST
Investigating
We are currently investigating this issue.
Posted Jun 30, 2022 - 18:13 SAST
This incident affected: Third-party Platforms (Nedbank card acquiring).