Mobicred Degraded performance

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Apr 09, 2026 - 13:48 SAST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 09, 2026 - 11:35 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2026 - 10:40 SAST

Investigating

We are currently observing failures on Mobicred transactions with the error: “Failed (900.100.100) – unexpected communication error with connector/acquirer.”

This has been escalated to Mobicred for investigation, and we will provide updates as soon as more information becomes available.

If you have any questions or concerns, please contact support@peachpayments.com or your account
Posted Apr 09, 2026 - 09:51 SAST
This incident affected: Third-party Platforms (Mobicred).