Standard Bank experiencing high volumes of rejections
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Dec 26, 2022 - 11:38 SAST
Identified
We are experiencing low success rate on Standard Bank transactions as users are unable to authenticate transactions due to a problem with their banking app

We will continue to monitor and update as this progresses
Posted Dec 26, 2022 - 11:04 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).