Nedbank Direct EFT - IOS degraded performance

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Jan 30, 2025 - 15:06 SAST

Investigating

We are seeing iOS/Safari issues where Nedbank Direct EFT is not loading in i-frames - we are working with our Nedbank partners to remedy this problem as soon as possible
Posted Mar 14, 2024 - 10:47 SAST
This incident affected: Third-party Platforms (Nedbank Direct EFT).