Payout intermittent downtime-peachpay.co.za

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 10:18 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 26, 2026 - 09:54 SAST

Investigating

The Peach Payouts service provider is currently experiencing intermittent downtime, resulting in timeouts when accessing the payout portal. The team is actively working to resolve the issue and we will provide updates as progress is made.

If you have any questions or concerns, please contact support@peachpayments.com or reach out to your account manager.
Posted Jan 26, 2026 - 09:42 SAST
This incident affected: Peach Payout Services.