Investec EFTSecure currently disabled
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Aug 05, 2022 - 10:41 SAST
Investigating
Please Note: Investec bank is currently disabled on our EFTsecure service due to Technical issues on their banking Portal.
Posted Aug 04, 2022 - 10:05 SAST
This incident affected: Third-party Platforms (EFT Secure).