Capitec Degraded
Incident Report for Peach Payments
Resolved
We have been informed by Capitec that the issue is now resolved. The team is on stand-by for monitoring purposes.

For any query, please reach out to support@peachpayments.com with all the relevant information and the team will assist. Thank you
Posted Jul 19, 2024 - 13:36 SAST
Identified
Peach has been informed that Capitec has a workaround to fix, but it's going to be incremental. Crowdstrike's international incident is the cause

We are seeing recovery. There will still be some latent issues that Capitec Team is working to mop up. Thank you.
Posted Jul 19, 2024 - 09:54 SAST
Investigating
Capitec Pay - a SOS process has been started
We are currently experiencing instability that is impacting payments.

We will keep you updated as we progress.

Here is what we know so far:
Impacted systems - Electronic Payments, including Capitec Pay
Total or Intermittent - Total
Impact on the client - Clients will get an error when logging into the app.

Our sincerest apologies for any inconvenience caused.

During this time, customers may experience intermittent downtime. The CapitecPay team are working to resolve and in case of any issue, please reach out to support@peachpayments.com with any questions or concerns or reach out to your Peach Payments Account Manager.
Posted Jul 19, 2024 - 07:52 SAST
This incident affected: Third-party Platforms (Debit Orders, Issuing systems for Card processing).