Masterpass is not currently responding to transactions
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jul 30, 2022 - 11:20 SAST
Monitoring
Masterpass has resolved the issue and notified Peach Payments:
Please note that the Masterpass service recovered at 16:16, and the platform has been stable since then. We will continue to monitor.

An update will follow on the root cause.
Posted Jul 29, 2022 - 17:49 SAST
Update
Masterpass team have provided a update to Peach:
Update

Kindly note that the Masterpass service is still currently unavailable. Our teams are working with our hosting provider to the service operational again.

We do apologize for the inconvenience caused.
Posted Jul 29, 2022 - 15:22 SAST
Update
Kindly note that Masterpass is still currently unavailable. We are waiting on our hosting provider to Resolver the issue.

We do apologize for the inconvenience caused.

A further update will follow.
Posted Jul 29, 2022 - 14:46 SAST
Investigating
Masterpass team have notified Peach Payments:
Kindly note that we are currently having connectivity issues with our Hosting provider. Our support teams are working to resolve the issue as soon as possible.

Feedback will follow.
Posted Jul 29, 2022 - 13:58 SAST
This incident affected: Third-party Platforms (Scan to Pay (Masterpass)).