Payment Links Sandbox: emails not working
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 11:09 SAST
Investigating
Sending Payments Links in sandbox via email is currently not working.

Our team are looking into this and we will update with any findings.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Apr 11, 2024 - 10:54 SAST
This incident affected: Plugins and Platforms (Payment Links).