Absa card acquiring - degraded performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Apr 06, 2024 - 06:12 SAST
Investigating
We are investigating degraded performance on Absa card acquiring.
Posted Apr 06, 2024 - 01:38 SAST
This incident affected: Third-party Platforms (Absa card acquiring).