In-store card processing - Transaction failures
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Nov 08, 2024 - 14:14 SAST
Update
Please note we're currently seeing intermittent errors on In-store Card Processing.

Our team is currently investigating this and we will provide updates as they become available.

Please reach out to support@peachpayments.co with any questions or concerns.
Posted Nov 08, 2024 - 14:06 SAST
Investigating
We are currently investigating this issue.
Posted Nov 08, 2024 - 14:02 SAST
This incident affected: In-store card processing (In-store card processing - Absa Card Present).