High rate of declines for M-PESA transactions

Incident Report for Peach Payments

Identified

The issue has been identified by the M-PESA team, and a fix is being implemented.
Posted Jun 10, 2026 - 05:24 SAST

Investigating

We are currently reaching out to our downstream partner to determine the high rate of rejections. We will update as we are able to determine the cause.
Posted Jun 10, 2026 - 04:52 SAST
This incident affects: Third-party Platforms (MPESA).