Nedbank planned maintenance - CHG0150459 - 07 June 2026

Scheduled for Jun 7, 00:00 - 06:00 SAST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 02, 2026 - 12:07 SAST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 02, 2026 - 12:06 SAST

Scheduled

Nedbank will be performing software maintenance/upgrades to optimise the resilience and
performance of their network on 00:00 (midnight) to 06:00am on Sunday, 07 June 2026. During the maintenance window, in-flight transactions may be impacted.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jun 02, 2026 - 10:45 SAST
This scheduled maintenance affects: Third-party Platforms (Nedbank card acquiring).