Peach In-store Degraded Performance

Incident Report for Peach Payments

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 13:06 SAST

Update

We are continuing to investigate on the issue. This does not affect E-commerce card processing.
Posted Apr 30, 2026 - 11:53 SAST

Update

We are continuing to investigate this issue.
Posted Apr 30, 2026 - 07:40 SAST

Investigating

Peach in-store processing service is currently experiencing degraded performance. Our team is working on resolving this as soon as possible.

We apologise for any inconvenience caused and will continue to update this status page as we make progress.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 30, 2026 - 07:34 SAST
This incident affects: Peach card processing platform and In-store card processing (In-store card processing - Absa Card Present, In-store card processing - Nedbank Card Present).