Issue with Capitec payments
Incident Report for Peach Payments
Resolved
This has been resolved by the team at Capitec.

please reach out to support@peachpayments.com with any questions or concerns
Posted Apr 16, 2024 - 11:48 SAST
Investigating
Please note Capitec is currently experiencing issues with electronic payments.

Impacted systems - Electronic Payments, including Capitec Pay
Total or Intermittent - Total
Impact on the client - Electronic payments are failing, clients will get an error when logging into the app.

The Capitec team is investigating, we will provide an update as soon as there is more information

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Apr 16, 2024 - 11:31 SAST
This incident affected: Peach card processing platform and Third-party Platforms (Capitec Pay).