In-store intermittent downtime

Incident Report for Peach Payments

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2026 - 08:42 SAST

Update

We are still working with the acquirer to restore this connection and we will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 10, 2026 - 08:19 SAST

Update

We are working with the acquirer to restore this connection, we will continue to update as the status is updated.
Posted Apr 10, 2026 - 04:42 SAST

Investigating

We are currently experiencing intermittent rejections with in-store card processing, which may cause some transactions to fail unexpectedly. Our team is actively investigating the problem and working to resolve it as quickly as possible. We apologize for any inconvenience and appreciate your patience.

If you have any queries or concerns, please reach out to your Account Manager or send a email to support@peachpayments.com
Posted Apr 10, 2026 - 01:39 SAST
This incident affects: In-store card processing (In-store card processing - Absa Card Present).