Capitec Pay - Severity 2 – Instability
Incident Report for Peach Payments
Resolved
Capitec Pay Services Restored


Capitec Pay services have been restored, and we will keep monitoring.

Our sincerest apologies for any inconvenience caused.
Please reach out to us via support@peachpayments.com or your Peach Payments account manager.
Posted Jul 08, 2024 - 13:04 SAST
Investigating
Capitec Pay has confirmed:
We are currently experiencing some instability that is impacting payments.

We will keep you updated as we progress.

Here is what we know so far:
Impacted systems - Electronic Payments, including Capitec Pay
Total or Intermittent - Intermittent
Impact on the client - some clients will get an error when logging into the app.

Our sincerest apologies for any inconvenience caused.
Please reach out to us via support@peachpayments.com or your Peach Payments account manager.
Posted Jul 08, 2024 - 09:51 SAST
This incident affected: Third-party Platforms (Capitec Pay).