Capitec Pay - intermittent performance
Incident Report for Peach Payments
Resolved
CapitecPay: Downtime on the App

Services are restored, and we will keep monitoring.

Our sincerest apologies for any inconvenience caused.
Thank you for your continued support.
If you have any questions, please reach out to our support team to assist - support@peachpayments.com or reach out to your Peach Payments account manager.
Posted Sep 26, 2023 - 12:19 SAST
Investigating
CapitecPay: Downtime on the App


Downtime on App Tuesday 26th September 8h22am start time - 8h39am end time.

Services are restored, and we will keep monitoring.


Our sincerest apologies for any inconvenience caused.

Thank you for your continued support.
If you have any questions, please reach out to our support team to assist - support@peachpayments.com or reach out to your Peach Payments account manager.
Posted Sep 26, 2023 - 09:44 SAST
This incident affected: Third-party Platforms (Capitec Pay).