Capitec App Issues
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Nov 07, 2024 - 11:32 SAST
Investigating
Please note that Capitec is currently experiencing issues with their app. This is resulting in high error rates for Capitec Pay.

The Capitec team is currently investigating and we will provide updates as they progress.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Nov 07, 2024 - 09:28 SAST
This incident affected: Third-party Platforms (Capitec Pay).