FNB-Issued Card Payment Authentication Failures – (800.100.152)

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 17:06 SAST

Monitoring

We are actively monitoring a technical incident affecting FNB-issued cards.

Issue Summary:

Customers may experience debits on their accounts, followed by a transaction decline from FNB with the response code “05: Do Not Honor.”

Current Status:

FNB has confirmed that their systems are currently undergoing recovery. We remain in close communication with their team and will update this status page as soon as full resolution and stability are confirmed.

Thank you for your patience and understanding as we work through this external issue.
Posted Nov 28, 2025 - 11:58 SAST
This incident affected: Third-party Platforms (FNB card acquiring).