Mobicred transaction experiencing degraded performance on Checkout

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted May 31, 2025 - 05:17 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 30, 2025 - 11:01 SAST

Investigating

Mobicred transactions processing on Checkout integration is currently experiencing degraded performance resulting in merchants' customers not being able to enter their OTP to complete payments. Our team is investigating the issue and working to resolve it as soon as possible.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted May 30, 2025 - 10:14 SAST
This incident affected: Third-party Platforms (Mobicred).